EastFax Web API 介绍

EastFax Web API
EastFax Web API 介绍

接口介绍

EastFax Web API提供以WEB请求调用的方式实现的EastFax客户端功能，使用此接口的用户可以按照开发规范提交基于Http的POST/GET协议调用接口实现EastFax客户端应用，用户开发的客户端应用可部署在独立的服务器上，用户如下图：

此接口提供给客户调用的功能主要包括：
1． EastFax部门组织架构及用户信息的访问
2． EastFax公共签审及个人签审理流程信息的访问
3． EastFax用户传真（接收的传真、发送的传真、签审的传真、签审任务）的访问及管理操作
4． EastFax传真草稿的创建管理发送
5． EastFax公共地址簿访问及个人地址簿管理
通过此接口进行二次开发基本可实现一个完整功能的EastFax客户端，同时此接口开发与开发语言无关，只需按照接口规范提交基于HTTP的请求即可。

接口开发基础说明

基于EastFax Web API进行二次开发，首先需申请EastFaxWebAPI开发授权，并获得经EastFax生成的app_key和app_secret。并安装EastFaxServer及EastFaxWeb相关组件。

EastFax Web API基于Http协议提交请求参数至http://EastFaxWebURL/api/EastFaxWebAPI.php （请将"http://EastFaxWebURL/"替换为EastFax Web Client访问地址）

注意：
所有请求和响应数据均使用utf-8格式。URL中的所有参数最好做好urlencode编码以防止中文内容传输过程中乱码。所有更新提交数据的操作如（eastfax.draft.add、eastfax.user.login等）强制使用http post方法，查询类接口方式不限制。

API系统级参数

参数名称 | 类型 | 是否必须 | 描述
method | String | 是 | API接口方法名称
sessionid | String | 可选 | 会话ID
format | String | 是 | 返回数据格式(json,xml)
app_key | String | 是 | 由EastFax授权的应用标识名
sign | String | 是 | API输入参数签名字串，详见签名规则说明

接口方法级参数说明

根据不同接口方法，此类型参数各异，详细请参看API接口方法参考内容。

返回数据格式说明

接口响应提供两种数据格式，XML格式及JSON格式。

列表数据XML数据格式示例：

列表数据JSON数据格式示例：

错误响应XML格式示例：

错误响应JSON格式示例：

SIGN签名生成规则

API系统级参数sign使用如下规则生成：

根据参数名称将所有提交的参数（包括系统级参数和接口方法级参数）按照参数名称做升序排序，然后对参数名和参数值连接后，在后面加上app_secret。如请求参数包括："参数1=value1，参数2=value2，参数3=value3"。app_secret为0FD47B013335D68879B18FAABD8F40E6。

此步骤生成字串 "参数1value1参数2value2参数3value30FD47B013335D68879B18FAABD8F40E6"。
计算上一步骤生成字符串的md5十六进制字符串值，转成大写格式。
最后将此32位字符串当做一个请求参数，名称为sign。

接口调用示例程序

EastFax Web API提供接口调用示例程序以方便开发者对接口调用参数及返回数据进行测试。

通过http://EastFaxWebURL/api/demo/访问EastFax Web API示例程序。（请将"http://EastFaxWebURL/"替换为EastFax Web Client访问地址）

1． 首先输入EastFax提供的app_key和app_secret;
2． 选择需要调用的API类型及API方法后，示例程序将会自动显示该API方法相关的参数；
3． 根据需要输入API参数值后，点击“获取SIGN”按钮，示例程序会根据您输入的所有参数生成sign验证参数；
4． sign生成完成后，点击“调用接口”按钮即向服务器提交调用请求，接口返回数据将显示在页面下方的文本框中。

Copyright (C) 2004-2010 Forwave Technology. All Rights Reserved.


快速开发入门

EastFax Web API 快速开发入门

基础说明

EastFax Web API提供的均是作为传真客户端的功能接口调用，因为在进行任何有效的接口调用前，首选需要调用用户登录接口eastfax.user.login进行登录，登录成功后取得sessionid，作为后续操作接口调用的必要参数。

用户登录

调用用户登录接口，首先根据API接口方法参考中eastfax.user.login的方法级参数定义，需要传入account,password,ipaddress,forcelogin。根据API系统级参数sign的生成规则，首先生成sign。

然后通过http协议提交POST请求到http://EastFaxWebURL/api/EastFaxWebAPI.php（请将"http://EastFaxWebURL/"替换为EastFax Web Client访问地址），请求参数如下：

提交成功后，服务器返回如下：

从以上返回的xml数据中取得sessionid后，即可进行后续的接口调用；

传真发送

如需调用接口完成传真发送的功能，将会涉及到以下几步骤的接口调用：

1． 调用eastfax.user.login，登录成功后，获取到sessionid；
2． 调用eastfax.draft.add，添加传真草稿，成功后获取到draftid；
3． 调用eastfax.draft.attachupload，给创建的草稿增加需发送的传真附件；
4． 调用eastfax.draft.send，提交传真发送。

经过以上步骤的接口调用后，传真即提交至传真服务器进行虚拟转换并进入发送队列。

传真签审

发起一个签审传真，将会涉及到以下几步骤的接口调用：

1． 调用eastfax.user.login，登录成功后，获取到sessionid；
2． 调用eastfax.draft.add，通过flowaccounts参数指定签审流程，添加签审传真草稿成功后获取到draftid；
3． 调用eastfax.draft.attachupload，给创建的草稿增加需发送的传真附件；
4． 调用eastfax.draft.send，提交传真发送。

经过以上步骤的接口调用后，传真即提交至传真服务器进行虚拟转换并由服务器完成签审流程的发起。

相应步骤的签审人可对签审任务进行审批处理：

1． 调用eastfax.user.login，登录成功后，获取到sessionid；
2． 调用eastfax.faxlist.getflowtask获得所有的待签审传真任务；获取到相应的需处理的签审传真的faxid；
3． 调用eastfax.fax.approve进行传真签审的审批通过或退回操作。

对于签审成功的传真，签审发起人可调用eastfax.faxlist.getflowfax接口获取到已完成签审流程的传真，如需发送签审成功的传真调用eastfax.fax.approvesend即可。

对于签审退回的传真可通过以下步骤完成重发的操作：

1． 调用eastfax.user.login，登录成功后后，获取到sessionid；
2． 调用eastfax.faxlist.getflowfax接口获取到签审退回的传真；
3． 调用eastfax.draft.add添加一个新的传真草稿，在部分传真信息无需修改的情况下可传入调用eastfax.fax.get接口获取被退回传真原始信息；
4． 调用eastfax.draft.attachupload添加传真附件，也可直接设定附件为“USERFAX:FAXID”即指定使用原始退回传真的附件内容作为新传真草稿的附件；
5． 重发签审的草稿创建完成后，调用eastfax.fax.resendflowfax重发退回的签审传真。

接收传真

如需接收查看传真，可通过以下接口的调用：

1． 调用eastfax.user.login，登录成功后，获取到sessionid；
2． 调用eastfax.faxlist.getinbox，获取已接收的传真列表信息；
3． 调用eastfax.fax.getfile，传入传真ID参数，可获取到相应传真图片文件查看URL；
4． 调用eastfax.fax.get，传入传真ID参数，可获取传真的详细信息。


%%phrase%%

API接口方法参考

用户API

方法 | 说明
eastfax.user.login | 用户登录系统
eastfax.user.logout | 用户登出系统
eastfax.user.update | 更新个人信息
eastfax.user.get | 获取单个用户信息
eastfax.user.changepassword | 用户修改登录密码
eastfax.user.list | 获取用户列表

组织架构API

方法 | 说明
eastfax.server.list | 获取集团传真服务器列表
eastfax.server.departlist | 获取部门列表

传真列表读取API

方法 | 说明
eastfax.faxlist.getdraft | 获取传真草稿列表
eastfax.faxlist.getongoing | 获取待发送传真列表
eastfax.faxlist.getinbox | 获取已接收的传真列表
eastfax.faxlist.getoutbox | 获取发送的传真列表
eastfax.faxlist.getflowtask | 获取签审任务传真列表
eastfax.faxlist.getflowfax | 获取签审的传真列表
eastfax.faxlist.gettrash | 获取垃圾箱的传真列表

传真操作API

方法 | 说明
eastfax.draft.get | 获取单个传真草稿信息
eastfax.draft.add | 添加传真草稿
eastfax.draft.update | 更新传真草稿信息
eastfax.draft.delete | 删除指定的传真草稿
eastfax.draft.attachupload | 添加传真草稿附件
eastfax.draft.attachdelete | 删除传真草稿附件
eastfax.draft.send | 传真草稿提交发送
eastfax.fax.get | 获取传真属性
eastfax.fax.cancel | 取消传真发送
eastfax.fax.delete | 删除传真至垃圾箱
eastfax.fax.restore | 恢复垃圾箱中的传真
eastfax.fax.forward | 内部传真转发
eastfax.fax.resend | 重新发送传真
eastfax.fax.update | 修改传真属性
eastfax.fax.resendflowfax | 重发退回的签审传真
eastfax.fax.approve | 传真签审操作
eastfax.fax.approvesend | 发送签审成功的传真
eastfax.fax.getfile | 获取传真文件

签审流程信息API

方法 | 说明
eastfax.flow.publiclist | 获取公共签审流程列表
eastfax.flow.privatelist | 获取个人签审流程列表
eastfax.flow.privateupdate | 更新个人签审流程信息

地址簿API

方法 | 说明
eastfax.abook.publiclist | 获取公共联系人列表
eastfax.abook.publicgrouplist | 获取公共联系人组别列表
eastfax.abook.privatelist | 获取个人联系人列表
eastfax.abook.privateedit | 新增或更新个人联系人
eastfax.abook.privatedel | 删除个人联系人
eastfax.abook.privategrouplist | 获取个人联系人组别列表
eastfax.abook.privategroupedit | 新增或修改个人联系人组别
eastfax.abook.privategroupdel | 删除个人联系人组别
eastfax.abook.get | 获取单个联系人信息


eastfax.user.login

eastfax.user.login 参考

说明

提供用户登录系统的方法

输入参数

名称 | 类型 | 必须 | 描述 | 示例
account | String | 是 | 用户登录帐号 | User001
password | String | 是 | 用户登录密码 | Password
ipaddress | String | 可选 | 登录者IP地址 | 192.168.1.1
forcelogin | Boolean | 可选 | 是否强制登陆 | True

返回结果

名称 | 类型 | 描述
sessionid | String | 会话ID
user | User | 登入成功的用户帐号信息


eastfax.user.logout

eastfax.user.logout 参考

说明

提供用户退出系统的方法

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |

返回结果

名称 | 类型 | 描述
result | Boolean | 退出执行结果


eastfax.user.update

eastfax.user.update 参考

说明

更新用户帐号信息的方法

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
autofaxtomail | Boolean | 可选 | 是否自动转发传真到邮件 | False
brepflow | Boolean | 可选 | 是否开启传真代签 | False
repflowaccount | String | 可选 | 传真代签人帐号 | User001
breprcv | Boolean | 可选 | 允许他人代收传真 | False
reprcvaccount | String | 可选 | 代收人帐号 | User002
telext | String | 可选 | 电话分机 | 288
relbiz | String | 可选 | 商务电话 | 65650000
mobile | String | 可选 | 移动电话 | 13800119900
email | String | 可选 | 电子邮件地址 | user@company.com
msn | String | 可选 | MSN帐号 | user@msn.com
qq | String | 可选 | QQ帐号 |

返回结果

名称 | 类型 | 描述
user | User | 修改后的用户帐号信息


eastfax.user.changepassword

eastfax.user.changepassword 参考

说明

修改用户密码的方法

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
oldpassword | String | 是 | 旧密码 | oldpassword
newpassword | String | 必须 | 新密码 | newpassword

返回结果

名称 | 类型 | 描述
result | Boolean | 修改密码结果


eastfax.user.get

eastfax.user.get 参考

说明

获取单个用户信息的方法

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
userid | String | 是 | 用户ID | 102

返回结果

名称 | 类型 | 描述
user | User | 用户帐号信息


eastfax.user.list

eastfax.user.list 参考

说明

获取符合条件的用户列表信息的方法

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
departid | String | 是 | 用户所属部门ID | 1
serverid | String | 可选 | 所属集团传真服务器ID | 23KUX5
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
user_items | User[] | 用户信息列表
total_results | Number | 符合条件的结果数量


eastfax.server.list

eastfax.server.list 参考

说明

获取所有集团传真服务器信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |

返回结果

名称 | 类型 | 描述
groupserver | GroupServer[] | 集团传真服务器信息列表


eastfax.server.departlist

eastfax.server.departlist 参考

说明

获取组织结构部门列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
serverid | String | 可选 | 集团传真服务器ID | 12H95W
parentid | Number | 可选 | 父级部门ID | 0

返回结果

名称 | 类型 | 描述
department | Department[] | 集团传真服务器信息列表


eastfax.faxlist.getdraft

eastfax.faxlist.getdraft 参考

说明

获取传真草稿列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
subject | String | 可选 | 传真主题条件关键字 |
receiver | String | 可选 | 传真接收者关键字 |
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
faxlist_items | DraftFax[] | 传真草稿信息列表
total_results | Number | 符合条件的结果数量


eastfax.faxlist.getongoing

eastfax.faxlist.getongoing 参考

说明

获取待发送传真列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
subject | String | 可选 | 传真主题条件关键字 |
receiver | String | 可选 | 传真接收者关键字 |
status | Number | 可选 | 待发送状态(1:转换队列,2:正转换,3:转换失败) | 1
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
faxlist_items | DraftFax[] | 待发送传真信息列表
total_results | Number | 符合条件的结果数量


eastfax.faxlist.getinbox

eastfax.faxlist.getinbox 参考

说明

获取已接收的传真列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
subject | String | 可选 | 传真主题条件关键字 |
sender | String | 可选 | 传真发送者关键字 |
start_recvtime | String | 可选 | 查询接收时间开始：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
end_recvtime | String | 可选 | 查询接收时间结束：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
faxlist_items | InboxFax[] | 已接收的传真信息列表
total_results | Number | 符合条件的结果数量


eastfax.faxlist.getoutbox

eastfax.faxlist.getoutbox 参考

说明

获取发送的传真列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
subject | String | 可选 | 传真主题条件关键字 |
receiver | String | 可选 | 传真接收者关键字 |
start_sendtime | String | 可选 | 查询发送时间开始：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
end_sendtime | String | 可选 | 查询发送时间结束：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
status | Number | 可选 | 发送状态(0:正在发送,1:发送成功,2:发送失败) | 1
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
faxlist_items | OutboxFax[] | 发送的传真信息列表
total_results | Number | 符合条件的结果数量


eastfax.faxlist.getflowtask

eastfax.faxlist.getflowtask 参考

说明

获取签审任务传真列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
subject | String | 可选 | 传真主题条件关键字 |
flowuser | String | 可选 | 传真签审发起者关键字 |
start_flowtime | String | 可选 | 查询签审发起时间开始：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
end_flowtime | String | 可选 | 查询签审发起时间结束：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
faxlist_items | TaskFax[] | 签审任务传真信息列表
total_results | Number | 符合条件的结果数量


eastfax.faxlist.getflowfax

eastfax.faxlist.getflowfax 参考

说明

获取签审的传真列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
subject | String | 可选 | 传真主题条件关键字 |
status | Number | 可选 | 签审传真状态(0:签审中,1:签审成功,2:签审退回) | 1
start_flowtime | String | 可选 | 查询签审发起时间开始：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
end_flowtime | String | 可选 | 查询签审发起时间结束：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
faxlist_items | FlowFax[] | 签审任务传真信息列表
total_results | Number | 符合条件的结果数量


eastfax.faxlist.gettrash

eastfax.faxlist.gettrash 参考

说明

获取垃圾箱中的传真列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
subject | String | 可选 | 传真主题条件关键字 |
start_deletetime | String | 可选 | 查询删除时间开始：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
end_deletetime | String | 可选 | 查询删除时间结束：格式：yyyy-MM-dd HH:mm:ss | 2010-01-01 12:00:00
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
faxlist_items | TrashFax[] | 垃圾箱中的传真信息列表
total_results | Number | 符合条件的结果数量


eastfax.draft.get

eastfax.draft.get 参考

说明

获取单个传真草稿信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
drfatid | Number | 必须 | 传真草稿ID | 10

返回结果

名称 | 类型 | 描述
draft | DraftFax[] | 传真草稿信息


eastfax.draft.add

eastfax.draft.add 参考

说明

新增传真草稿

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
receiver | String | 可选 | 传真接收者 | 02165610000;0105690000
subject | String | 可选 | 传真主题 | 发货单
comments | String | 可选 | 传真备注 | 备注
important | Number | 可选 | 重要性标记(0:低,1:普通,2:高) | 0
headerfooter | Number | 可选 | 页眉页脚(0:无,1:一般,2:详细,3:简洁) | 1
flowaccounts | String | 可选 | 签审流程 | user1 > user2 | user3 > user5
forcesendtime | String | 可选 | 指定发送时间 | 2010-01-01 12:00:00
busymoreretry | Number | 可选 | 忙音多发次数 | 1
failedretry | Number | 可选 | 错误重发设置(0:同服务端设置,1:不重发,2:错误后重发) | 2
retrytime | Number | 可选 | 重发次数 | 3
delaytime | Number | 可选 | 重发延时(秒) | 120
playvoice | Boolean | 可选 | 发送时播放语音 | 1
successreceiversms | Boolean | 可选 | 发送成功短信通知接收者 | 1
errorsendersms | Boolean | 可选 | 发送失败短信通知发送者 | 1
selectedline | Number | 可选 | 线路选择(-1:自动路由) | -1
resolution | Number | 可选 | 传真分辨率(0:服务器设置,1:低,2:高) | 0

返回结果

名称 | 类型 | 描述
draftid | Number | 新增成功的传真草稿ID
updatetime | String | 最后更新时间


eastfax.draft.update

eastfax.draft.update 参考

说明

更新传真草稿信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
draftid | Number | 是 | 传真草稿ID |
receiver | String | 可选 | 传真接收者 | 02165610000;0105690000
subject | String | 可选 | 传真主题 | 发货单
comments | String | 可选 | 传真备注 | 备注
important | Number | 可选 | 重要性标记(0:低,1:普通,2:高) | 0
headerfooter | Number | 可选 | 页眉页脚(0:无,1:一般,2:详细,3:简洁) | 1
flowaccounts | String | 可选 | 签审流程 | user1 > user2 | user3 > user5
forcesendtime | String | 可选 | 指定发送时间 | 2010-01-01 12:00:00
busymoreretry | Number | 可选 | 忙音多发次数 | 1
failedretry | Number | 可选 | 错误重发设置(0:同服务端设置,1:不重发,2:错误后重发) | 2
retrytime | Number | 可选 | 重发次数 | 3
delaytime | Number | 可选 | 重发延时(秒) | 120
playvoice | Boolean | 可选 | 发送时播放语音 | 1
successreceiversms | Boolean | 可选 | 发送成功短信通知接收者 | 1
errorsendersms | Boolean | 可选 | 发送失败短信通知发送者 | 1
selectedline | Number | 可选 | 线路选择(-1:自动路由) | -1
resolution | Number | 可选 | 传真分辨率(0:服务器设置,1:低,2:高) | 0

返回结果

名称 | 类型 | 描述
draftid | Number | 传真草稿ID
updatetime | String | 最后更新时间


eastfax.draft.delete

eastfax.draft.delete 参考

说明

删除传真草稿

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
draftid | Number | 是 | 传真草稿ID |

返回结果

名称 | 类型 | 描述
result | Boolean | 删除执行结果


eastfax.draft.attachupload

eastfax.draft.attachupload 参考

说明

添加传真草稿的附件

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
draftid | Number | 是 | 传真草稿ID |
filepath | String | 是 | 传真附件全路径或用户传真附件 如需将用户已有的传真内容作为新草稿附件，通过“USERFAX:FAXID“进行指定 | C:\test.doc 或 USERFAX:20091010_120012BC

返回结果

名称 | 类型 | 描述
draftid | Number | 传真草稿ID
updatetime | String | 最后更新时间


eastfax.draft.attachdelete

eastfax.draft.attachdelete 参考

说明

删除传真草稿的附件

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
draftid | Number | 是 | 传真草稿ID |
fileid | String | 是 | 传真附件ID |

返回结果

名称 | 类型 | 描述
draftid | Number | 传真草稿ID
updatetime | String | 最后更新时间


eastfax.draft.send

eastfax.draft.send 参考

说明

传真草稿提交发送

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
draftid | Number | 是 | 传真草稿ID |

返回结果

名称 | 类型 | 描述
fax | DraftFax | 返回faxid,updatetime,status属性


eastfax.fax.get

eastfax.fax.get 参考

说明

获取单个用户传真的信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU
faxtype | String | 是 | 传真类别(inbox:收到的传真,flowfax:签审的传真,task:签审任务,outbox:发送的传真) | inbox
lang | String | 是 | 返回属性语言(zh-cn:简体中文,zh-tw:繁体中文,en:英文,jp:日文) | zh-cn

返回结果

名称 | 类型 | 描述
fax | InboxFax OutboxFax TaskFax FlowFax | 根据参数faxtype，返回不同类型的传真属性


eastfax.fax.cancel

eastfax.fax.cancel 参考

说明

取消传真发送

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU

返回结果

名称 | 类型 | 描述
faxid | String | 传真ID
result | Boolean | 取消发送结果


eastfax.fax.delete

eastfax.fax.delete 参考

说明

传真删除到垃圾箱

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU
faxtype | String | 是 | 传真类别(inbox:收到的传真,flowfax:签审的传真,task:签审任务,outbox:发送的传真) | inbox

返回结果

名称 | 类型 | 描述
faxid | String | 传真ID
result | Boolean | 删除传真操作结果


eastfax.fax.restore

eastfax.fax.restore 参考

说明

从垃圾箱中恢复传真

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU
faxtype | String | 是 | 传真类别(inbox:收到的传真,flowfax:签审的传真,task:签审任务,outbox:发送的传真) | inbox

返回结果

名称 | 类型 | 描述
faxid | String | 传真ID
result | Boolean | 恢复传真操作结果


eastfax.fax.forward

eastfax.fax.forward 参考

说明

内部转发传真

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU
subject | String | 是 | 传真主题 | 内部转发传真
receivers | String | 是 | 内部转发传真接收人列表,多个接收人用分号";"分隔 | user001;user002;user003

返回结果

名称 | 类型 | 描述
fax | OutboxFax | 返回faxid,receiver等字段


eastfax.fax.resend

eastfax.fax.resend 参考

说明

重新发送失败的传真

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU

返回结果

名称 | 类型 | 描述
faxid | String | 传真ID
result | Boolean | 重发提交结果


eastfax.fax.update

eastfax.fax.update 参考

说明

修改用户传真属性

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU
subject | String | 是 | 传真主题 | 修改后的传真主题
read | Boolean | 是 | 已读标志 | 1
important | Number | 是 | 重要性标记(0:低,1:普通,2:高) | 2

返回结果

名称 | 类型 | 描述
faxid | String | 传真ID
result | Boolean | 修改属性提交结果


eastfax.fax.resendflowfax

eastfax.fax.resendflowfax 参考

说明

重发退回的签审传真

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU
draftid | Number | 可选 | 重发签审使用的草稿,不指定时对签审退回的传真不做修改直接重发 | 10

返回结果

名称 | 类型 | 描述
faxid | String | 传真ID
result | Boolean | 重发提交结果


eastfax.fax.approve

eastfax.fax.approve 参考

说明

传真签审任务审批操作

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU
accept | Boolean | 是 | 是否同意 | 1
opinion | String | 是 | 审批意见 | 同意
comments | String | 可选 | 签审备注 | 备注信息

返回结果

名称 | 类型 | 描述
faxid | String | 传真ID
result | Boolean | 审批提交结果


eastfax.fax.approvesend

eastfax.fax.approvesend 参考

说明

提交发送签审成功的传真

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU

返回结果

名称 | 类型 | 描述
faxid | String | 传真ID
result | Boolean | 发送提交结果


eastfax.fax.getfile

eastfax.fax.getfile 参考

说明

获取传真文件访问URL

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
faxid | String | 是 | 传真ID | 20100501_132012YU
filetype | String | 是 | 文件类型:(tiff,pdf,png,gif) | tiff
page | String | 可选 | 指定返回传真页 | 1

返回结果

名称 | 类型 | 描述
fileurl | String | 传真文件访问URL


eastfax.flow.publiclist

eastfax.flow.publiclist 参考

说明

获取公共签审流程

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |

返回结果

名称 | 类型 | 描述
flowlist | FlowInfo[] | 公共签审流程列表
agreelist | Array | 常用签审同意意见列表
returnlist | Array | 常用签审退回意见列表


eastfax.flow.privatelist

eastfax.flow.privatelist 参考

说明

获取个人签审流程

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |

返回结果

名称 | 类型 | 描述
flowlist | FlowInfo[] | 个人签审流程列表
agreelist | Array | 常用签审同意意见列表
returnlist | Array | 常用签审退回意见列表


eastfax.flow.privateupdate

eastfax.flow.privateupdate 参考

说明

更新个人签审流程

输入参数

名称 类型 必须 描述 示例
sessionid String 是
会话ID
flowlist String 是
个人签审流程列表字串
流程之间用“||”分隔
流程名称与流程定义之间用"::"分隔
流程A::user1 > user2 || 流程B::user2 > user3

返回结果

名称 | 类型 | 描述
result | Boolean | 个人流程更新结果


eastfax.abook.publiclist

eastfax.abook.publiclist 参考

说明

获取公共联系人列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
groupid | Number | 是 | 联系人分组ID | 1
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
contact_items | Contact[] | 公共联系人列表
total_results | Number | 符合条件的结果总数


eastfax.abook.publicgrouplist

eastfax.abook.publicgrouplist 参考

说明

获取公共联系人组别列表

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |

返回结果

名称 | 类型 | 描述
publicgroup | ContactGroup[] | 公共联系人组别列表


eastfax.abook.privatelist

eastfax.abook.privatelist 参考

说明

获取个人联系人列表信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
groupid | Number | 是 | 联系人分组ID | 1
page_no | Number | 可选 | 返回结果页数 | 1
page_size | Number | 可选 | 每页返回数量 | 25

返回结果

名称 | 类型 | 描述
contact_items | Contact[] | 个人联系人列表
total_results | Number | 符合条件的结果总数


eastfax.abook.privateedit

eastfax.abook.privateedit 参考

说明

新增或修改个人联系人

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
contactid | Number | 可选 | 个人联系人ID,如不指即为创建新个人联系人 |
truename | String | 是 | 姓名 | 张三
groupid | Number | 可选 | 个人联系人组别ID | 2
company | String | 可选 | 公司 | 领先科技有限公司
departname | String | 可选 | 部门 | 市场部
position | String | 可选 | 职务 | 助理
fax | String | 可选 | 传真号码 | 01050609900
telbiz | String | 可选 | 商务电话 | 01089300000
telhome | String | 可选 | 家庭电话 |
eastfax | String | 可选 | EastFax传真地址 |
mobile | String | 可选 | 移动电话 |
email | String | 可选 | 电子邮件 | zhangsan@company.com
web | String | 可选 | 网址 |
msn | String | 可选 | MSN帐号 |
qq | String | 可选 | QQ帐号 |

返回结果

名称 | 类型 | 描述
groupid | String | 个人联系人组别ID
result | Boolean | 提交操作结果


eastfax.abook.privatedel

eastfax.abook.privatedel 参考

说明

删除个人联系人组别

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
contactid | Number | 是 | 个人联系人ID | 10

返回结果

名称 | 类型 | 描述
result | Boolean | 提交操作结果


eastfax.abook.privategrouplist

eastfax.abook.privategrouplist 参考

说明

获取个人联系人组别列表

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |

返回结果

名称 | 类型 | 描述
privategroup | ContactGroup[] | 个人联系人组别列表


eastfax.abook.privategroupedit

eastfax.abook.privategroupedit 参考

说明

新增或修改个人联系人组别

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
groupid | Number | 可选 | 个人组别ID,如不指即为创建新组别 |
groupname | String | 是 | 个人联系人组别名称 | 供应商

返回结果

名称 | 类型 | 描述
groupid | String | 个人联系人组别ID
result | Boolean | 提交操作结果


eastfax.abook.privategroupdel

eastfax.abook.privategroupdel 参考

说明

删除个人联系人组别

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
groupid | Number | 是 | 个人联系人组别ID | 10

返回结果

名称 | 类型 | 描述
result | Boolean | 提交操作结果


eastfax.abook.get

eastfax.abook.get 参考

说明

获取单个联系人信息

输入参数

名称 | 类型 | 必须 | 描述 | 示例
sessionid | String | 是 | 会话ID |
id | String | 是 | 联系人ID 公共联系人格式为"public_xxx" 个人联系人格式为"private_xxx" | private_10

返回结果

名称 | 类型 | 描述
contact | Contact | 个人联系人详细信息


%%phrase%%

API 数据结构参考
数据类型名称 | 说明
User | 用户信息
Department | 组织架构部门信息
GroupServer | 集团传真服务器信息
Role | 用户角色功能权限
DraftFax | 传真草稿信息
InboxFax | 已接收的传真信息
OutboxFax | 发送的传真信息
TaskFax | 传真签审任务信息
FlowFax | 签审传真信息
TrashFax | 垃圾箱中的传真信息
AttachFile | 传真草稿附件信息
FlowInfo | 签审流程定义信息
Contact | 联系人信息
ContactGroup | 联系人分组信息


User

User 数据结构参考

说明

用户数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
Userid | Number | 用户数字ID | 1000
Account | String | 用户帐号 | wsq001
Truename | String | 用户姓名 | 王强
Department | String | 所属部门 | 技术中心/大客户
GroupServer | String | 所属传真服务器ID | D9SAX0
Position | String | 职位 | 主管
FaxExtension | String | 传真分机号 | 1000
telExtension | String | 电话分机号 | 1000
BusinessPhone | String | 商务电话 | 021-56560000
MobilePhone | String | 移动电话 | 13801818000
Email | String | 电子邮件 | wsq001@company.com
AutoFaxToMail | Boolean | 是否自动转发传真到邮件 | 1
Locked | Boolean | 是否锁定 | 0
bRepFlowFax | Boolean | 是否开启传真代签 | 1
RepFlowFaxAccount | String | 传真代签人帐号 | user001
AllowRepRcv | Boolean | 是否允许他人代收传真 | 1
BRRIncIntFax | Boolean | 是否同时代收内部转发的传真 | 1
RepRcvAccount | String | 代收人帐号 | user002
UserRole | Role | 用户功能权限 |


Department

Department 数据结构参考

说明

部门数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
DepartId | Number | 部门ID | 1000
DepartName | String | 部门名称 | 销售部
DepartPid | Number | 上级部门ID | 0


GroupServer

GroupServer 数据结构参考

说明

集团传真服务器数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
ServerID | String | 集团传真服务器ID | 20H35W
ServerName | String | 服务器标识名 | 总部001
ServerIP | String | 服务器网络地址 | 10.10.23.101


Role

Role 数据结构参考

说明

角色功能权限数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
defaultFlow | String | 默认签审流程 | user1 > user2 > user3
FaxSendPriority | Number | 传真优先级 | 1
Faxproc_fwdexternal | Boolean | 允许外部转发传真 | 1
Faxproc_fwdinternal | Boolean | 允许内部转发传真 | 1
Faxproc_mailto | Boolean | 允许转发传真到邮件 | 1
Faxproc_postill | Boolean | 允许传真批注 | 1
Faxproc_print | Boolean | 允许打印传真 | 1
Faxproc_saveas | Boolean | 允许另存传真 | 1
Faxproc_sign | Boolean | 允许手写签名 | 1
Faxrecv_external | Boolean | 允许接收外部传真 | 1
Faxrecv_notifysms | Boolean | 允许新传真短信通知 | 1
Faxsend_ddd | Boolean | 允许国内长途 | 1
Faxsend_external | Boolean | 允许外发传真 | 1
Faxsend_idd | Boolean | 允许国际长途 | 1
Faxsend_prioritysend | Boolean | 允许重要传真优先发送 | 1
Faxsend_retryset | Boolean | 允许错误重发设置 | 1
Faxsend_selectline | Boolean | 允许指定线路发送 | 1
Faxsend_userflow | Boolean | 允许自定义签审流程 | 1
Sms_groupsend | Boolean | 允许群发短信 | 1
Sms_resultnotify | Boolean | 允许发送结果短信通知 | 1
Sms_send | Boolean | 允许发送短信 | 1


DraftFax

DraftFax 数据结构参考

说明

传真草稿数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
Draftid | Number | 传真草稿ID | 1
Receiver | String | 传真接收者 | 02156550000;01089801199
Subject | String | 传真主题 | 采购项目清单
Comments | String | 传真备注 |
Import | Number | 重要性标记(0:低,1:普通,2:高) | 1
Headerfooter | String | 页眉页脚 |
Flowaccounts | String | 签审流程 | user001 > user002 > user003
forceSendTime | String | 指定发送时间 | 2010-08-01 12:00:00
BusymoreRetry | Number | 忙音多发次数 | 3
FailedRetry | Number | 错误重发设置(0:同服务端设置,1:不重发,2:错误后重发) | 1
RetryTime | Number | 重发次数 | 3
PlayVoice | Boolean | 发送时播放语音 | 1
successReceiverSms | Boolean | 发送成功短信通知接收者 | 0
ErrorSenderSms | Boolean | 发送失败短信通知发送者 | 0
SelectedLine | Number | 线路选择(-1:自动路由) | -1
Resolution | Number | 传真分辨率(0:服务器设置,1:低,2:高) | 0
Result | String | 转换结果描述 |
Status | Number | 草稿状态 0: 未提交发送 1: 虚拟打印转换队列中 2: 正在虚拟打印转换 3: 虚拟打印转换失败 | 0
Attachfiles | AttachFile[] | 传真附件列表 |
Updatetime | String | 最后更新时间 | 2010-08-01 12:00:00


InboxFax

InboxFax 数据结构参考

说明

已接收的传真数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
FaxID | String | 用户传真ID | 20100510_140438QA
Sender | String | 传真发送者 | 02156550000
Subject | String | 传真主题 | 采购项目清单
Recvtime | String | 传真接收时间 | 2010-05-10 13:04:38
Pages | Number | 传真页数 | 10
FwdUser | String | 内部转发者 |
FwdTime | String | 内部转发时间 |
Read | Boolean | 是否已读 | 0
Import | Number | 重要性标记 | 1
Size | Number | 传真文件大小 | 1023400


OutboxFax

OutboxFax 数据结构参考

说明

发送的传真数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
FaxID | String | 用户传真ID | 20100510_150538DB
Receiver | String | 传真接收者 | 02156550000
Subject | String | 传真主题 | 采购项目清单
Sendtime | String | 传真发送时间 | 2010-05-10 15:05:38
Pages | Number | 传真页数 | 10
Read | Boolean | 已读标记 | 1
Import | Number | 重要性标记 | 1
Size | Number | 传真文件大小 | 1023400
Status | Number | 状态(0:正在发送,1:发送成功,2:发送失败) | 1
Createtime | String | 创建时间 |
Resultdesc | String | 发送结果描述 | 发送成功


TaskFax

TaskFax 数据结构参考

说明

签审任务传真数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
FaxID | String | 用户传真ID | 20100510_150538DB
Receiver | String | 传真接收者 | 02156550000
Subject | String | 传真主题 | 采购项目清单
Flow | String | 签审流程 | user002 > user003
starttime | String | 签审发起时间 | 2010-05-10 15:05:38
Pages | Number | 传真页数 | 10
Read | Boolean | 已读标记 | 1
Import | Number | 重要性标记 | 1
Size | Number | 传真文件大小 | 1023400


FlowFax

FlowFax 数据结构参考

说明

签审的传真数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
FaxID | String | 用户传真ID | 20100510_150538DB
Receiver | String | 传真接收者 | 02156550000
Subject | String | 传真主题 | 采购项目清单
Flow | String | 签审流程 | user002 > user003
starttime | String | 签审发起时间 | 2010-05-10 15:05:38
Pages | Number | 传真页数 | 10
Read | Boolean | 已读标记 | 1
Import | Number | 重要性标记 | 1
Size | Number | 传真文件大小 | 1023400
Status | Number | 状态(0:签审中,1:签审成功,2:签审退回) | 1
Resultdesc | String | 结果状态描述 |


TrashFax

TrashFax 数据结构参考

说明

垃圾箱的传真数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
FaxID | String | 用户传真ID | 20100510_150538DB
FaxType | String | 传真类型(inbox,outbox) | inbox
Receiver | String | 传真接收者 |
Sender | String | 传真发送者 | 02156550000
Subject | String | 传真主题 | 采购项目清单
Pages | Number | 传真页数 | 10
Read | Boolean | 已读标记 | 1
Import | Number | 重要性标记 | 1
Size | Number | 传真文件大小 | 1023400
DeleteTime | String | 删除时间 | 2010-05-10 15:05:38


AttachFile

AttachFile 数据结构参考

说明

传真草稿附件数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
FileID | String | 传真附件ID |
FileName | String | 附件显示 |


FlowInfo

FlowInfo 数据结构参考

说明

传真签审流程定义数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
Flowname | String | 签审流程名称 | 合同传真审批流程
Flowaccounts | String | 签审流程定义 | user001 > user002


Contact

Contact 数据结构参考

说明

联系人属性数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
Contactid | Number | 联系人数字ID | 10
Truename | String | 姓名 | 王强
Groupid | Number | 联系人分组ID | 1
Company | String | 公司 | 领先科技公司
Department | String | 部门 | 市场部
Position | String | 职务 | 助理
telbiz | String | 商务电话 | 021-56560000
telhome | String | 家庭电话 | 021-64501234
eastfax | String | EastFax传真地址 | 123@10.10.10.1
fax | String | 传真号码 | 58908888
mobile | String | 移动电话 | 13818180000
email | String | 电子邮件 | wangqiang@company.com
msn | String | MSN帐号 |
qq | String | QQ帐号 |


ContactGroup

ContactGroup 数据结构参考

说明

联系人分组数据结构

属性字段列表

名称 | 类型 | 描述 | 示例
groupid | Number | 联系人组别数字ID | 10
groupname | String | 联系人组别名称 | 供应商


API接口错误返回码

API接口错误返回码

说明

API接口错误返回码

错误返回码详细列表

错误码 | 描述
0 | 未知错误
1 | App_key不正确
2 | 调用方法参数不正确
3 | sign签名校验参数不正确
11 | 传入参数不正确
12 | EastFax用户未正确登录
13 | EastFax用户会话超时
14 | 用户重复登录，且与上次登录位置相同
15 | 用户已登录，与上次登录位置不同
17 | 登录用户不存在或登录密码错误
18 | 用户旧密码不匹配
19 | 登录用户帐号被锁定
20 | 用户登录发生异常
21 | 传真文件不存在
29 | 用户相关记录不存在
201 | 指定ID的传真草稿不存在
202 | 指定ID的传真草稿附件不存在
203 | 传真附件格式系统部支持
204 | 传真未指定收件人
205 | 传真未添加任何附件
206 | 传真草稿的签审流程中不能包含发起者自己
207 | 指定ID的签审退回传真不存在
208 | 传真签审未指定签审流程
209 | 联系人组别已存在
210 | 联系人ID无效
211 | 指定ID的联系人不存在